summaryrefslogtreecommitdiff
path: root/luasec-prosody-git/luasec-prosody.patch
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
commit49ad89f8716725e050afb4166c45812a0be83be4 (patch)
tree52515dbcdeb6669c37fd813bfb56a20fe24093de /luasec-prosody-git/luasec-prosody.patch
parentdbde5ffd47db3eefb6e8429776f57a12270f5f5b (diff)
parentf385d6d42405b12a753f33fa81c16c8f05f76de0 (diff)
downloadarch-packages-49ad89f8716725e050afb4166c45812a0be83be4.tar.gz
merge
Diffstat (limited to 'luasec-prosody-git/luasec-prosody.patch')
-rw-r--r--luasec-prosody-git/luasec-prosody.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/luasec-prosody-git/luasec-prosody.patch b/luasec-prosody-git/luasec-prosody.patch
new file mode 100644
index 0000000..2d2672b
--- /dev/null
+++ b/luasec-prosody-git/luasec-prosody.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c8aa90f..31e27c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ # Inform the location to intall the modules
+-LUAPATH ?= /usr/share/lua/5.1
+-LUACPATH ?= /usr/lib/lua/5.1
++LUAPATH ?= /usr/share/lua/5.2
++LUACPATH ?= /usr/lib/lua/5.2
+
+ # Compile with build-in LuaSocket's help files.
+ # Comment this lines if you will link with non-internal LuaSocket's help files
+diff --git a/src/ssl.lua b/src/ssl.lua
+index 1b062f6..1b63e70 100644
+--- a/src/ssl.lua
++++ b/src/ssl.lua
+@@ -4,6 +4,8 @@
+ --
+ ------------------------------------------------------------------------------
+
++local unpack = unpack or table.unpack
++
+ local core = require("ssl.core")
+ local context = require("ssl.context")
+ local x509 = require("ssl.x509")