summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
commit49ad89f8716725e050afb4166c45812a0be83be4 (patch)
tree52515dbcdeb6669c37fd813bfb56a20fe24093de
parentdbde5ffd47db3eefb6e8429776f57a12270f5f5b (diff)
parentf385d6d42405b12a753f33fa81c16c8f05f76de0 (diff)
downloadarch-packages-49ad89f8716725e050afb4166c45812a0be83be4.tar.gz
merge
-rw-r--r--Makefile14
-rw-r--r--README.rst4
-rw-r--r--lua5.3/LICENSE30
-rw-r--r--lua5.3/PKGBUILD56
-rw-r--r--lua5.3/liblua.so.patch53
-rw-r--r--lua5.3/lua.pc20
-rw-r--r--luasec-prosody-git/PKGBUILD67
-rw-r--r--luasec-prosody-git/luasec-prosody.patch26
8 files changed, 266 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 085f453..82c1415 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,14 @@
# packages
-SLNUNICODE = slnunicode-git
LUAMD5 = lua-md5-git
-SWIG = swig-git
+LUASEC = luasec-prosody-git
+LUAWORK = lua5.3
MUTT_NNTP = mutt-nntp
+SLNUNICODE = slnunicode-git
+SWIG = swig-git
# collections
PKGS = $(SLNUNICODE) $(LUAMD5) $(SWIG) $(MUTT_NNTP)
+PKGS += $(LUASEC) $(LUAWORK)
VERFY = $(PKGS:%=verify-%)
SOURCE = $(PKGS:%=source-%)
@@ -35,10 +38,12 @@ $(SOURCE):
@echo
# individual targets
-slnunicode: $(SLNUNICODE)
+lua5.3: $(LUAWORK)
luamd5: $(LUAMD5)
-swig: $(SWIG)
+luasec: $(LUASEC)
mutt-nntp: $(MUTT_NNTP)
+slnunicode: $(SLNUNICODE)
+swig: $(SWIG)
info:
@echo settings:
@@ -52,5 +57,6 @@ info:
@echo
@echo package targets:
@echo "slnunicode" "luamd5" "swig"
+ @echo "mutt-nntp" "luasec" "lua5.3"
.PHONY: info all $(PKGS) clean $(VERFY) source $(SOURCE)
diff --git a/README.rst b/README.rst
index 3b0c741..98cd21b 100644
--- a/README.rst
+++ b/README.rst
@@ -28,6 +28,8 @@ Currently comprises development versions of these packages:
(#) LuaMD5_. (``lua-md5-git``)
(#) `Selene Unicode`_ (``slnunicode-git``)
+(#) `Luasec Prosody`_ (``luasec-prosody-git``),
+(#) `Lua 5.3 work`_ (``lua53``),
(#) SWIG_ (``swig-git``)
(#) Mutt/NNTP
@@ -36,6 +38,8 @@ Currently comprises development versions of these packages:
.. _LuaMD5: https://aur.archlinux.org/packages/lua-md5-git/
.. _Selene Unicode: https://aur.archlinux.org/packages/slnunicode-git
.. _SWIG: https://aur.archlinux.org/packages/swig-git
+.. _Luasec Prosody: https://aur.archlinux.org/packages/luasec-prosody-git
+.. _Lua 5.3 work: https://aur.archlinux.org/packages/lua53/
.. _me: mailto:phg42.2a@gmail.com
diff --git a/lua5.3/LICENSE b/lua5.3/LICENSE
new file mode 100644
index 0000000..7f1344f
--- /dev/null
+++ b/lua5.3/LICENSE
@@ -0,0 +1,30 @@
+Lua License
+
+Lua is free software distributed under the terms of the MIT license
+reproduced below; it may be used for any purpose, including commercial
+purposes, at absolutely no cost without having to ask us. The only
+requirement is that if you do use Lua, then you should give us credit
+by including the appropriate copyright notice somewhere in your product
+or its documentation. For details, see this.
+
+Copyright © 1994–2013 Lua.org, PUC-Rio.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
diff --git a/lua5.3/PKGBUILD b/lua5.3/PKGBUILD
new file mode 100644
index 0000000..6f44922
--- /dev/null
+++ b/lua5.3/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Philipp Gesang <phg42.2a@gmail.com>
+# Derived from the Lua 5.2 and 5.1 PKGBUILDs in extra which lists
+# these guys as contributors:
+# Contributor: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=lua53
+pkgver=5.3.0_work1
+pkgrel=2
+pkgdesc='Powerful light-weight programming language designed for extending applications, version 5.3 working draft'
+arch=('i686' 'x86_64')
+url='http://www.lua.org/'
+depends=('readline')
+license=('MIT')
+options=('!makeflags' '!emptydirs')
+source=('http://www.lua.org/work/lua-5.3.0-work1.tar.gz'
+ 'liblua.so.patch'
+ 'LICENSE'
+ 'lua.pc')
+md5sums=('d4053ee55741eab5ecd7061326577586'
+ '42ae5d526cc73695ee05ca8db6b19754'
+ '5d236d27128ef36bbc8f228faaf76f7f'
+ '3369fab35575e718eae71884674ba387')
+
+build() {
+ cd "lua-${pkgver/_/-}"
+ patch -p1 -i "$srcdir/liblua.so.patch"
+ export CFLAGS="$CFLAGS -fPIC"
+ sed "s/%VER%/${pkgver%.*}/g;s/%REL%/$pkgver/g" ../lua.pc > lua.pc
+ sed -r -e '/^LUA_(SO|A|T)=/ s/lua/lua5.3/' -e '/^LUAC_T=/ s/luac/luac5.3/' -i src/Makefile
+ make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
+}
+
+package() {
+ cd "lua-${pkgver/_/-}"
+ make \
+ TO_BIN="lua5.3 luac5.3" \
+ TO_LIB="liblua5.3.a liblua5.3.so liblua5.3.so.5.3 liblua5.3.so.5.3.0" \
+ INSTALL_DATA="cp -d" \
+ INSTALL_TOP="$pkgdir/usr" \
+ INSTALL_INC="$pkgdir/usr/include/lua5.3" \
+ INSTALL_MAN="$pkgdir/usr/share/man/man1" \
+ install
+ install -Dm644 lua.pc "$pkgdir/usr/lib/pkgconfig/lua5.3.pc"
+ install -d "$pkgdir/usr/share/doc/lua5.3"
+ install -m644 doc/*.{gif,png,css,html} "$pkgdir/usr/share/doc/lua5.3"
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -s liblua5.3.so "$pkgdir/usr/lib/liblua.so.5.3"
+ ln -s liblua5.3.so "$pkgdir/usr/lib/liblua.so.$pkgver"
+ cd "$pkgdir/usr/share/man/man1"
+ mv lua.1 lua5.3.1
+ mv luac.1 luac5.3.1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/lua5.3/liblua.so.patch b/lua5.3/liblua.so.patch
new file mode 100644
index 0000000..7c02d02
--- /dev/null
+++ b/lua5.3/liblua.so.patch
@@ -0,0 +1,53 @@
+diff -ru lua-5.3.0-work1/Makefile lua-5.3.0-work1-patched/Makefile
+--- lua-5.3.0-work1/Makefile 2013-06-04 04:12:29.000000000 +0200
++++ lua-5.3.0-work1-patched/Makefile 2013-07-10 11:04:27.826555020 +0200
+@@ -10,7 +10,7 @@
+ # so take care if INSTALL_TOP is not an absolute path. See the local target.
+ # You may want to make INSTALL_LMOD and INSTALL_CMOD consistent with
+ # LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
+-INSTALL_TOP= /usr/local
++INSTALL_TOP= /usr
+ INSTALL_BIN= $(INSTALL_TOP)/bin
+ INSTALL_INC= $(INSTALL_TOP)/include
+ INSTALL_LIB= $(INSTALL_TOP)/lib
+@@ -52,7 +52,7 @@
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$(V) R=$(R)
+
+ test: dummy
+ src/lua -v
+diff -ru lua-5.3.0-work1/src/Makefile lua-5.3.0-work1-patched/src/Makefile
+--- lua-5.3.0-work1/src/Makefile 2013-06-04 15:41:55.000000000 +0200
++++ lua-5.3.0-work1-patched/src/Makefile 2013-07-10 11:01:46.822761150 +0200
+@@ -29,6 +29,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+
+ LUA_A= liblua.a
++LUA_SO= liblua.so
+ CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+ lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+ ltm.o lundump.o lvm.o lzio.o
+@@ -43,7 +44,7 @@
+ LUAC_O= luac.o
+
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
+-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
+ ALL_A= $(LUA_A)
+
+ # Targets start here.
+@@ -59,6 +60,11 @@
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
++$(LUA_SO): $(CORE_O) $(LIB_O)
++ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO)
++
+ $(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+
diff --git a/lua5.3/lua.pc b/lua5.3/lua.pc
new file mode 100644
index 0000000..615fce2
--- /dev/null
+++ b/lua5.3/lua.pc
@@ -0,0 +1,20 @@
+V=%VER%
+R=%REL%
+
+prefix=/usr
+INSTALL_BIN=${prefix}/bin
+INSTALL_INC=${prefix}/include/5.3
+INSTALL_LIB=${prefix}/lib
+INSTALL_MAN=${prefix}/man/man1
+INSTALL_LMOD=${prefix}/share/lua/${V}
+INSTALL_CMOD=${prefix}/lib/lua/${V}
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include/5.3
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua5.3 -lm
+Cflags: -I${includedir}
diff --git a/luasec-prosody-git/PKGBUILD b/luasec-prosody-git/PKGBUILD
new file mode 100644
index 0000000..fd798ae
--- /dev/null
+++ b/luasec-prosody-git/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Philipp Gesang <phg42.2a@gmail.com>
+
+pkgname=luasec-prosody-git
+_gitname=luasec
+_gitbranch=master
+pkgver=19.063e8a8
+pkgrel=2
+pkgdesc="A fork of LuaSec, an SSL and crypto library for Lua."
+arch=("i686" "x86_64")
+url="https://github.com/brunoos/luasec/wiki"
+license=("MIT")
+groups=()
+depends=("lua" "openssl")
+makedepends=("git")
+provides=("luasec")
+conflicts=("luasec-hg")
+#install=
+source=("${_gitname}::git+https://github.com/brunoos/${_gitname}#branch=${_gitbranch}"
+ "luasec-prosody.patch") # build for Lua 5.2
+noextract=()
+sha512sums=("SKIP"
+ "459969712d74fd2137f0cf7c7acc227bfe1e097e99937c2b897c625e96d9de3d20265634a6e49418f4ef5cf037435d2e07b0a1747a850d110aa207ef6735c7b7")
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}"
+ msg "Connecting to GIT server ..."
+
+ if [[ -d "${_gitname}" ]]; then
+ cd "${_gitname}" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "${_gitroot}" "${_gitname}"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build ..."
+
+ rm -rf "${srcdir}/${_gitname}-build"
+ git clone "${srcdir}/${_gitname}" "${srcdir}/${_gitname}-build"
+ cd "${srcdir}/${_gitname}-build"
+
+ msg "Rewrite paths in Makefile to build for Lua 5.2"
+ git apply "${srcdir}/luasec-prosody.patch"
+
+ ## build
+ msg "Compile for target \"linux\""
+ if [[ "${LDFLAGS}" =~ "-Wl" ]]
+ then
+ msg "Fixing LDFLAGS (remove \"-Wl\")"
+ LDFLAGS=${LDFLAGS/-Wl,/}
+ echo "LDFLAGS=\"${LDFLAGS}\""
+ fi
+ make linux
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-build"
+ make DESTDIR="${pkgdir}/" install
+ install -Dm0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/luasec-prosody-git/luasec-prosody.patch b/luasec-prosody-git/luasec-prosody.patch
new file mode 100644
index 0000000..2d2672b
--- /dev/null
+++ b/luasec-prosody-git/luasec-prosody.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c8aa90f..31e27c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ # Inform the location to intall the modules
+-LUAPATH ?= /usr/share/lua/5.1
+-LUACPATH ?= /usr/lib/lua/5.1
++LUAPATH ?= /usr/share/lua/5.2
++LUACPATH ?= /usr/lib/lua/5.2
+
+ # Compile with build-in LuaSocket's help files.
+ # Comment this lines if you will link with non-internal LuaSocket's help files
+diff --git a/src/ssl.lua b/src/ssl.lua
+index 1b062f6..1b63e70 100644
+--- a/src/ssl.lua
++++ b/src/ssl.lua
+@@ -4,6 +4,8 @@
+ --
+ ------------------------------------------------------------------------------
+
++local unpack = unpack or table.unpack
++
+ local core = require("ssl.core")
+ local context = require("ssl.context")
+ local x509 = require("ssl.x509")