summaryrefslogtreecommitdiff
path: root/lua5.3/liblua.so.patch
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-09-10 18:08:09 +0200
commit49ad89f8716725e050afb4166c45812a0be83be4 (patch)
tree52515dbcdeb6669c37fd813bfb56a20fe24093de /lua5.3/liblua.so.patch
parentdbde5ffd47db3eefb6e8429776f57a12270f5f5b (diff)
parentf385d6d42405b12a753f33fa81c16c8f05f76de0 (diff)
downloadarch-packages-49ad89f8716725e050afb4166c45812a0be83be4.tar.gz
merge
Diffstat (limited to 'lua5.3/liblua.so.patch')
-rw-r--r--lua5.3/liblua.so.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/lua5.3/liblua.so.patch b/lua5.3/liblua.so.patch
new file mode 100644
index 0000000..7c02d02
--- /dev/null
+++ b/lua5.3/liblua.so.patch
@@ -0,0 +1,53 @@
+diff -ru lua-5.3.0-work1/Makefile lua-5.3.0-work1-patched/Makefile
+--- lua-5.3.0-work1/Makefile 2013-06-04 04:12:29.000000000 +0200
++++ lua-5.3.0-work1-patched/Makefile 2013-07-10 11:04:27.826555020 +0200
+@@ -10,7 +10,7 @@
+ # so take care if INSTALL_TOP is not an absolute path. See the local target.
+ # You may want to make INSTALL_LMOD and INSTALL_CMOD consistent with
+ # LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
+-INSTALL_TOP= /usr/local
++INSTALL_TOP= /usr
+ INSTALL_BIN= $(INSTALL_TOP)/bin
+ INSTALL_INC= $(INSTALL_TOP)/include
+ INSTALL_LIB= $(INSTALL_TOP)/lib
+@@ -52,7 +52,7 @@
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$(V) R=$(R)
+
+ test: dummy
+ src/lua -v
+diff -ru lua-5.3.0-work1/src/Makefile lua-5.3.0-work1-patched/src/Makefile
+--- lua-5.3.0-work1/src/Makefile 2013-06-04 15:41:55.000000000 +0200
++++ lua-5.3.0-work1-patched/src/Makefile 2013-07-10 11:01:46.822761150 +0200
+@@ -29,6 +29,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+
+ LUA_A= liblua.a
++LUA_SO= liblua.so
+ CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+ lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+ ltm.o lundump.o lvm.o lzio.o
+@@ -43,7 +44,7 @@
+ LUAC_O= luac.o
+
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
+-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
+ ALL_A= $(LUA_A)
+
+ # Targets start here.
+@@ -59,6 +60,11 @@
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
++$(LUA_SO): $(CORE_O) $(LIB_O)
++ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO)
++
+ $(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+