summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-09-04 14:01:35 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-09-04 14:01:35 +0200
commitf385d6d42405b12a753f33fa81c16c8f05f76de0 (patch)
tree3a9c8e8fd8e410dac741941a17fc5785239f85b9
parent66d667cd8b58d877fed04bc5f3d67938501a8277 (diff)
downloadarch-packages-f385d6d42405b12a753f33fa81c16c8f05f76de0.tar.gz
update luasec
-rw-r--r--luasec-prosody-git/PKGBUILD4
-rw-r--r--luasec-prosody-git/luasec-prosody.patch13
2 files changed, 15 insertions, 2 deletions
diff --git a/luasec-prosody-git/PKGBUILD b/luasec-prosody-git/PKGBUILD
index 2f86469..fd798ae 100644
--- a/luasec-prosody-git/PKGBUILD
+++ b/luasec-prosody-git/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=luasec-prosody-git
_gitname=luasec
_gitbranch=master
pkgver=19.063e8a8
-pkgrel=1
+pkgrel=2
pkgdesc="A fork of LuaSec, an SSL and crypto library for Lua."
arch=("i686" "x86_64")
url="https://github.com/brunoos/luasec/wiki"
@@ -19,7 +19,7 @@ source=("${_gitname}::git+https://github.com/brunoos/${_gitname}#branch=${_gitbr
"luasec-prosody.patch") # build for Lua 5.2
noextract=()
sha512sums=("SKIP"
- "38fcf53127e9b65ab79f68f5813fcf3149943c9abfe7e506ac7b67d00c9bc982dbd75c2c8faaf7dd0f248c67598f0292128b701e2a98ab1a4d0c47190191038a")
+ "459969712d74fd2137f0cf7c7acc227bfe1e097e99937c2b897c625e96d9de3d20265634a6e49418f4ef5cf037435d2e07b0a1747a850d110aa207ef6735c7b7")
pkgver() {
cd "${_gitname}"
diff --git a/luasec-prosody-git/luasec-prosody.patch b/luasec-prosody-git/luasec-prosody.patch
index 41d007f..2d2672b 100644
--- a/luasec-prosody-git/luasec-prosody.patch
+++ b/luasec-prosody-git/luasec-prosody.patch
@@ -11,3 +11,16 @@ index c8aa90f..31e27c8 100644
# Compile with build-in LuaSocket's help files.
# Comment this lines if you will link with non-internal LuaSocket's help files
+diff --git a/src/ssl.lua b/src/ssl.lua
+index 1b062f6..1b63e70 100644
+--- a/src/ssl.lua
++++ b/src/ssl.lua
+@@ -4,6 +4,8 @@
+ --
+ ------------------------------------------------------------------------------
+
++local unpack = unpack or table.unpack
++
+ local core = require("ssl.core")
+ local context = require("ssl.context")
+ local x509 = require("ssl.x509")