summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d743b4f..acc3138 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,9 +5,9 @@
[package]
name = "vtcol"
description = "Set Linux console color scheme"
-version = "0.42.5"
+version = "0.42.7"
authors = [ "Philipp Gesang <phg@phi-gamma.net>" ]
-repository = "https://github.com/phi-gamma/vtcol"
+repository = "https://gitlab.com/phgsng/vtcol"
keywords = [ "linux", "virtual_terminal", "tty", "console", "system" ]
readme = "README.rst"
license = "GPL-3.0"
@@ -15,12 +15,15 @@ edition = "2021"
[dependencies]
libc = "0.2"
+indoc = "1.0"
clap = { version = "2.33", optional = true }
anyhow = { version = "1.0", optional = true }
base64 = "0.13"
+slint = { version = "0.2", optional = true }
[features]
vtcol-bin = [ "anyhow", "clap" ]
+gui = [ "vtcol-bin", "slint" ]
[[bin]]
name = "vtcol"