summaryrefslogtreecommitdiff
path: root/luatex-svn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'luatex-svn/PKGBUILD')
-rw-r--r--luatex-svn/PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/luatex-svn/PKGBUILD b/luatex-svn/PKGBUILD
index f0e88ec..c981a42 100644
--- a/luatex-svn/PKGBUILD
+++ b/luatex-svn/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=luatex-svn
pkgrel=1
pkgdesc="The LuaTeX engine, current SVN trunk, standalone binary"
pkgver=r6111
-arch=(i686 x86_64)
+arch=(i686 x86_64 armv7h)
url="http://www.luatex.org"
# Luatex, Poppler: GPL2
# Fontforge: GPL (?)
@@ -16,7 +16,7 @@ url="http://www.luatex.org"
# libpng: libpng
license=('GPL2' 'boost' 'MIT' 'libpng' 'LGPL2.1')
depends=()
-makedepends=()
+makedepends=(subversion)
conflicts=()
source=()
@@ -36,10 +36,10 @@ prepare() {
if [[ -d "${_svnlocal}/.svn" ]]; then
msg "Reusing existing SVN repository at ${_svnlocal}"
cd "${_svnlocal}"
- svn update --username "${_svncred}" --password "${_svncred}"
+ svn update --no-auth-cache --username "${_svncred}" --password "${_svncred}"
else
msg "No local Subversion repo found, creating new one at ${_svnlocal}"
- svn checkout --username "${_svncred}" --password "${_svncred}" \
+ svn checkout --no-auth-cache --username "${_svncred}" --password "${_svncred}" \
"${_svnurl}" "${_svnlocal}"
fi
msg "Repo up to date"