summaryrefslogtreecommitdiff
path: root/lua5.3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'lua5.3/PKGBUILD')
-rw-r--r--lua5.3/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/lua5.3/PKGBUILD b/lua5.3/PKGBUILD
index 4658c28..e6241ed 100644
--- a/lua5.3/PKGBUILD
+++ b/lua5.3/PKGBUILD
@@ -13,20 +13,20 @@
#
pkgname=lua53
-pkgver=5.3.0_rc3
+pkgver=5.3.0_rc4
pkgrel=1
-pkgdesc='Powerful light-weight programming language designed for extending applications, third release candidate of version 5.3.0'
+pkgdesc='Powerful light-weight programming language designed for extending applications, fourth release candidate of version 5.3.0'
arch=('i686' 'x86_64')
url='http://www.lua.org/'
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
-source=('http://www.lua.org/work/lua-5.3.0-rc3.tar.gz'
+source=('http://www.lua.org/work/lua-5.3.0-rc4.tar.gz'
'liblua.so.patch'
'LICENSE'
'lua.pc')
-sha512sums=('5d6417d778988800a72a8c2503080ea6a483d8f2586f7d2e68e8ecb7ce5a562f5b5b78ada81b349c21c756bcdb68b0054b9f4a334cc1c866ca71c25707afd0fb'
+sha512sums=('2b423e70c4c992a08d28ef12f1d0b078f2ee7043cda302d93e9d59ff6ab79152bb4971455d37666a98cf5cfe3cafd3d16e30b33a11fd585743d5d817424a2d51'
'bcb85d5863685473dcff1e615cfbadaede09440e4fcab1d32ea1cd6fca543e4e549084901cc5df72089ef145e213a763c26570637c539b7689b6e4e5cd129941'
'4f2dcdf727fa87cb1a89e8f9e678b6245b7af1722c74d4c04adc865745c80a0ce292fd5c18787fb3c00ec44bfa07a49ffed2fcb71008a84f4464933ab4bd3d38'
'c91d5e7b1468ec773a4863fd8f360e5379626668242b856605fab634d5aa003e247992f23a6f41b511481b5468bd644fcb18e66e6f1f2514688f5653f06d1186')
@@ -34,7 +34,7 @@ sha512sums=('5d6417d778988800a72a8c2503080ea6a483d8f2586f7d2e68e8ecb7ce5a562f5b5
build() {
declare -r dstdir="lua-${pkgver/_/-}"
rm -rf -- "${dstdir}"
- mv "${dstdir%%-rc3}" "${dstdir}"
+ mv "${dstdir%%-rc4}" "${dstdir}"
cd "${dstdir}"
patch -p1 -i "${srcdir}/liblua.so.patch"
export CFLAGS="${CFLAGS} -fPIC"