summaryrefslogtreecommitdiff
path: root/context-mkiv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'context-mkiv/PKGBUILD')
-rw-r--r--context-mkiv/PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/context-mkiv/PKGBUILD b/context-mkiv/PKGBUILD
index 0d8d2a9..599bf95 100644
--- a/context-mkiv/PKGBUILD
+++ b/context-mkiv/PKGBUILD
@@ -12,8 +12,12 @@ depends=(luatex-svn context-git)
## mtxrun is part of Context; to execute it we need Luatex as the interpreter
makedepends=(rsync luatex-svn context-git)
conflicts=(context-minimals-git)
-source=(context-setup-env.sh)
-sha512sums=('17d82d422873abd4eac79660e4cf0eefd8cba7fca3fae0eaad832911a5066385ba18625ccc61638da4c91fd180c4bcf21a6cd7664cdb4248ef530fe6cc2c64b0')
+source=( \
+ context-setup-env.sh \
+ context-wrap-mtxrun.sh \
+)
+sha512sums=('92ede9be2a244a065cd133e7300d3c807c212e588eb164d941bb89eda9f72601101b754235bce06442e0e75793ce2de99053f094a8510811d4c8e84e9f445993'
+ '1151100c043c25c2a09f04ee1ef067a0f81a6f17aafb88446bb168242d70a069e8b0d351263df31fe02fa662660325dc568e96944ed06b2cf65a24e4a127a750')
# binaries and scripts installed with deps
readonly _luatex=/usr/bin/texlua
@@ -59,6 +63,7 @@ package() {
local texdst="${pkgdir}/usr/share/texmf"
local libdst="${pkgdir}/usr/lib"
local execdst="${pkgdir}/usr/bin"
+ local platformdst="${texdst}/texmf-linux/bin"
local subdirs=( texmf texmf-fonts texmf-modules )
cd context
install -dm755 "${texdst}"
@@ -67,8 +72,14 @@ package() {
done
# install symlink to Context git
ln -s /usr/share/context-git "${texdst}/texmf-context"
- # mktexlsr is the only script we take as-is
+
+ # move mtxrun out of the way, we’ll call it with the wrapper
+ install -dm755 "${platformdst}"
+ install -Dm755 texmf-linux/bin/mtxrun "${platformdst}"
install -dm755 "${execdst}"
+ install -Dm755 "${srcdir}/context-wrap-mtxrun.sh" "${execdst}/mtxrun"
+
+ # mktexlsr is the only script we take as-is
install -Dm755 texmf-linux/bin/mktexlsr "${execdst}"
install -dm755 "${libdst}"
install -Dm644 "${srcdir}/context-setup-env.sh" "${libdst}"