summaryrefslogtreecommitdiff
path: root/luasec-prosody-git/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2014-07-13 11:05:38 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2014-07-13 11:05:38 +0200
commitd35e217008fe9ad5fea4559c9298ef3b447ed294 (patch)
tree87b67e547a626e20e1fa52dcad368b6cc37cf373 /luasec-prosody-git/PKGBUILD
parente9d5a25c94a340b0f4f492550bb6552ba103d17b (diff)
downloadarch-packages-d35e217008fe9ad5fea4559c9298ef3b447ed294.tar.gz
luasec: fix PKGBUILD by removing patch in favor of sed
Diffstat (limited to 'luasec-prosody-git/PKGBUILD')
-rw-r--r--luasec-prosody-git/PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/luasec-prosody-git/PKGBUILD b/luasec-prosody-git/PKGBUILD
index fd798ae..f488618 100644
--- a/luasec-prosody-git/PKGBUILD
+++ b/luasec-prosody-git/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=luasec-prosody-git
_gitname=luasec
_gitbranch=master
-pkgver=19.063e8a8
-pkgrel=2
+pkgver=42.903efaf
+pkgrel=1
pkgdesc="A fork of LuaSec, an SSL and crypto library for Lua."
arch=("i686" "x86_64")
url="https://github.com/brunoos/luasec/wiki"
@@ -15,11 +15,9 @@ makedepends=("git")
provides=("luasec")
conflicts=("luasec-hg")
#install=
-source=("${_gitname}::git+https://github.com/brunoos/${_gitname}#branch=${_gitbranch}"
- "luasec-prosody.patch") # build for Lua 5.2
+source=("${_gitname}::git+https://github.com/brunoos/${_gitname}#branch=${_gitbranch}")
noextract=()
-sha512sums=("SKIP"
- "459969712d74fd2137f0cf7c7acc227bfe1e097e99937c2b897c625e96d9de3d20265634a6e49418f4ef5cf037435d2e07b0a1747a850d110aa207ef6735c7b7")
+sha512sums=("SKIP")
pkgver() {
cd "${_gitname}"
@@ -45,7 +43,8 @@ build() {
cd "${srcdir}/${_gitname}-build"
msg "Rewrite paths in Makefile to build for Lua 5.2"
- git apply "${srcdir}/luasec-prosody.patch"
+ sed -i "/LUAPATH/ cLUAPATH ?= ${pkgdir}/usr/share/lua/5.2" "Makefile"
+ sed -i "/LUACPATH/cLUACPATH ?= ${pkgdir}/usr/share/lua/5.2" "Makefile"
## build
msg "Compile for target \"linux\""