summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2015-01-12 19:34:50 +0100
committerPhilipp Gesang <phg@phi-gamma.net>2015-01-12 19:34:50 +0100
commitdfc4f9c02fbe7c353b5675c461680ab2ece26c32 (patch)
tree32c51e3d7dc076825d33718596af19c69f3c285f
parent93b3b2dadc0ca9db887d46ad7d72e2f36c13add0 (diff)
downloadarch-packages-dfc4f9c02fbe7c353b5675c461680ab2ece26c32.tar.gz
lua53: update for final (yeah!)
-rw-r--r--lua5.3/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/lua5.3/PKGBUILD b/lua5.3/PKGBUILD
index e6241ed..0f49cd4 100644
--- a/lua5.3/PKGBUILD
+++ b/lua5.3/PKGBUILD
@@ -9,19 +9,19 @@
#
# Before trying this out make sure you read the changelog:
#
-# http://www.lua.org/work/doc/#changes
+# http://www.lua.org/manual/5.3/readme.html#changes
#
pkgname=lua53
-pkgver=5.3.0_rc4
+pkgver=5.3.0
pkgrel=1
-pkgdesc='Powerful light-weight programming language designed for extending applications, fourth release candidate of version 5.3.0'
+pkgdesc='Powerful light-weight programming language designed for extending applications, version 5.3.0'
arch=('i686' 'x86_64')
url='http://www.lua.org/'
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
-source=('http://www.lua.org/work/lua-5.3.0-rc4.tar.gz'
+source=('http://www.lua.org/ftp/lua-5.3.0.tar.gz'
'liblua.so.patch'
'LICENSE'
'lua.pc')
@@ -32,9 +32,7 @@ sha512sums=('2b423e70c4c992a08d28ef12f1d0b078f2ee7043cda302d93e9d59ff6ab79152bb4
'c91d5e7b1468ec773a4863fd8f360e5379626668242b856605fab634d5aa003e247992f23a6f41b511481b5468bd644fcb18e66e6f1f2514688f5653f06d1186')
build() {
- declare -r dstdir="lua-${pkgver/_/-}"
- rm -rf -- "${dstdir}"
- mv "${dstdir%%-rc4}" "${dstdir}"
+ declare -r dstdir="lua-${pkgver}"
cd "${dstdir}"
patch -p1 -i "${srcdir}/liblua.so.patch"
export CFLAGS="${CFLAGS} -fPIC"
@@ -44,7 +42,7 @@ build() {
}
package() {
- declare -r dstdir="lua-${pkgver/_/-}"
+ declare -r dstdir="lua-${pkgver}"
cd "${dstdir}"
make \
TO_BIN="lua5.3 luac5.3" \