summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2016-09-05 23:49:03 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2016-09-05 23:49:03 +0200
commitd0cbc8b72dc47be67b41c7f51aa58650f54194d3 (patch)
tree3e71a7951f6a48e5ad6665fca191a1cb4e2d054f
parent370a47f1dd555479ec1eeec40f5066266d5a8972 (diff)
downloadarch-packages-d0cbc8b72dc47be67b41c7f51aa58650f54194d3.tar.gz
context-git: add preliminary PKGBUILD
-rw-r--r--context-git/PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/context-git/PKGBUILD b/context-git/PKGBUILD
new file mode 100644
index 0000000..bcdfaf5
--- /dev/null
+++ b/context-git/PKGBUILD
@@ -0,0 +1,52 @@
+# Context from Git mirror
+# Maintainer: Philipp Gesang <phg@phi-gamma.net>
+pkgname=context-git
+pkgver=3f59c56
+pkgrel=1
+pkgdesc="The ConTeXt typesetting system; sources from Git"
+arch=(any)
+url="http://pragma-ade.nl"
+license=('GPL2')
+groups=()
+depends=()
+makedepends=('git' 'luatex-svn')
+provides=()
+conflicts=(context-minimals-git)
+replaces=()
+backup=()
+options=()
+install=
+noextract=()
+sha256sums=('SKIP')
+
+_git_repo=bitbucket.org/phg/context-mirror.git
+_git_branch=beta
+_git_checkout=context-mirror-git
+source=("${_git_checkout}::git+https://${_git_repo}#branch=${_git_branch}")
+
+pkgver() {
+ cd "${_git_checkout}"
+ # no tags in mirror repo
+ git describe --always
+}
+
+build() {
+ cd "${srcdir}"
+ if [[ ! -d "${_git_checkout}" ]]; then
+ msg "expected repo checkout at ${srcdir}/${_git_checkout}"
+ exit -1
+ fi
+}
+
+package() {
+ local subdirs=( bibtex colors context doc fonts metapost scripts tex web2c )
+ local dst="${pkgdir}/usr/share/${pkgname}"
+ install -dm755 "${dst}"
+
+ cd "${srcdir}"
+ for dir in ${subdirs[@]} ; do
+ cp -ra "${_git_checkout}/${dir}" "${dst}/"
+ done
+}
+
+# vim:ft=sh:et:sw=2:ts=8