summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-07-03 15:34:49 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-07-03 15:34:49 +0200
commitb3a2590a3b92e20780c0903bf175ce7166142925 (patch)
tree5aa962cab586bc9b1d40c8f896d9762ca41387ec
parentb21549ab562e9f40deb0b181e41d1b97bc7a3b72 (diff)
downloadarch-packages-b3a2590a3b92e20780c0903bf175ce7166142925.tar.gz
add pkbuild for selene unicode
-rw-r--r--slnunicode-git/LICENSE19
-rw-r--r--slnunicode-git/PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/slnunicode-git/LICENSE b/slnunicode-git/LICENSE
new file mode 100644
index 0000000..17a059d
--- /dev/null
+++ b/slnunicode-git/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2005-2011 Malete Partner, Berlin, partner@malete.org
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+of the Software, and to permit persons to whom the Software is furnished to do
+so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/slnunicode-git/PKGBUILD b/slnunicode-git/PKGBUILD
new file mode 100644
index 0000000..8a3d719
--- /dev/null
+++ b/slnunicode-git/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philipp Gesang <phg42.2a@gmail.com>
+pkgname=slnunicode-git
+_gitname=slnunicode
+pkgver=20130703.gf80f1bc
+pkgrel=1
+pkgdesc="Unicode-aware replacement for the Lua string library from the Selene database."
+arch=("any")
+url="http://luaforge.net/projects/sln/"
+license=("custom")
+depends=("lua")
+source=("slnunicode::git+https://github.com/phi-gamma/${_gitname}"
+ "LICENSE")
+md5sums=('SKIP'
+ '18ad94b36b198743a0142b3ada1411d7')
+options=(!strip)
+_gitbranch="master"
+
+pkgver() {
+ cd $_gitname
+ # Package version is the date of the last commit + the SHA tag
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-//g'
+}
+
+build () {
+ cd $_gitname
+ gcc -O2 -fPIC -I/usr/include -c slnunico.c -o ./slnunico.o
+ gcc -O2 -fPIC -I/usr/include -c slnudata.c -o ./slnudata.o
+ gcc -shared -o unicode.so -L/usr/lib slnunico.o ./slnudata.o
+}
+
+package () {
+ cd $_gitname
+ install -Dm0755 "${srcdir}/${_gitname}/unicode.so" "${pkgdir}/usr/lib/lua/5.2/unicode.so"
+ install -Dm0644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}