summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-07-10 11:48:29 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-07-10 11:48:29 +0200
commitb0f53efff96249ec7941122567c9d6c977df946b (patch)
treeb61c9f041b2dc55266ab415de6bfd3b3fbbd8765
parented697a19a630434b84ddb6dd23901bb623903927 (diff)
downloadarch-packages-b0f53efff96249ec7941122567c9d6c977df946b.tar.gz
add lua 5.3.0 work build
-rw-r--r--Makefile6
-rw-r--r--lua5.3/LICENSE30
-rw-r--r--lua5.3/PKGBUILD56
-rw-r--r--lua5.3/liblua.so.patch53
-rw-r--r--lua5.3/lua.pc20
5 files changed, 163 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8b846e5..00f2d78 100644
--- a/Makefile
+++ b/Makefile
@@ -3,9 +3,10 @@ SLNUNICODE = slnunicode-git
LUAMD5 = lua-md5-git
SWIG = swig-git
LUASEC = luasec-prosody-git
+LUAWORK = lua5.3
# collections
-PKGS = $(SLNUNICODE) $(LUAMD5) $(SWIG) $(LUASEC)
+PKGS = $(SLNUNICODE) $(LUAMD5) $(SWIG) $(LUASEC) $(LUAWORK)
VERFY = $(PKGS:%=verify-%)
SOURCE = $(PKGS:%=source-%)
@@ -39,6 +40,7 @@ slnunicode: $(SLNUNICODE)
luamd5: $(LUAMD5)
swig: $(SWIG)
luasec: $(LUASEC)
+lua5.3: $(LUAWORK)
info:
@echo settings:
@@ -51,6 +53,6 @@ info:
@echo "all verify source"
@echo
@echo package targets:
- @echo "slnunicode" "luamd5" "swig" "luasec"
+ @echo "slnunicode" "luamd5" "swig" "luasec" "lua5.3"
.PHONY: info all $(PKGS) clean $(VERFY) source $(SOURCE)
diff --git a/lua5.3/LICENSE b/lua5.3/LICENSE
new file mode 100644
index 0000000..7f1344f
--- /dev/null
+++ b/lua5.3/LICENSE
@@ -0,0 +1,30 @@
+Lua License
+
+Lua is free software distributed under the terms of the MIT license
+reproduced below; it may be used for any purpose, including commercial
+purposes, at absolutely no cost without having to ask us. The only
+requirement is that if you do use Lua, then you should give us credit
+by including the appropriate copyright notice somewhere in your product
+or its documentation. For details, see this.
+
+Copyright © 1994–2013 Lua.org, PUC-Rio.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
diff --git a/lua5.3/PKGBUILD b/lua5.3/PKGBUILD
new file mode 100644
index 0000000..d6ec1e1
--- /dev/null
+++ b/lua5.3/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Philipp Gesang <phg42.2a@gmail.com>
+# Derived from the Lua 5.2 and 5.1 PKGBUILDs in extra which lists
+# these guys as contributors:
+# Contributor: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=lua53
+pkgver=5.3.0_work1
+pkgrel=1
+pkgdesc='Powerful light-weight programming language designed for extending applications, version 5.3 working draft'
+arch=('i686' 'x86_64')
+url='http://www.lua.org/'
+depends=('readline')
+license=('MIT')
+options=('!makeflags' '!emptydirs')
+source=('http://www.lua.org/work/lua-5.3.0-work1.tar.gz'
+ 'liblua.so.patch'
+ 'LICENSE'
+ 'lua.pc')
+md5sums=('d4053ee55741eab5ecd7061326577586'
+ '42ae5d526cc73695ee05ca8db6b19754'
+ '5d236d27128ef36bbc8f228faaf76f7f'
+ '3369fab35575e718eae71884674ba387')
+
+build() {
+ cd "lua-${pkgver/_/-}"
+ patch -p1 -i "$srcdir/liblua.so.patch"
+ export CFLAGS="$CFLAGS -fPIC"
+ sed "s/%VER%/${pkgver%.*}/g;s/%REL%/$pkgver/g" ../lua.pc > lua.pc
+ sed -r -e '/^LUA_(SO|A|T)=/ s/lua/lua5.3/' -e '/^LUAC_T=/ s/luac/luac5.3/' -i src/Makefile
+ make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
+}
+
+package() {
+ cd "lua-${pkgver/_/-}"
+ make \
+ TO_BIN="lua5.3 luac5.3" \
+ TO_LIB="liblua5.3.a liblua5.3.so liblua5.3.so.5.3 liblua5.3.so.5.3.0" \
+ INSTALL_DATA="cp -d" \
+ INSTALL_TOP="$pkgdir/usr" \
+ INSTALL_INC="$pkgdir/usr/include/lua5.3" \
+ INSTALL_MAN="$pkgdir/usr/share/man/man1" \
+ install
+ install -Dm644 lua.pc "$pkgdir/usr/lib/pkgconfig/lua5.3.pc"
+ install -d "$pkgdir/usr/share/doc/lua5.3"
+ install -m644 doc/*.{gif,png,css,html} "$pkgdir/usr/share/doc/lua5.3"
+ install -D -m644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -s liblua5.3.so "$pkgdir/usr/lib/liblua.so.5.3"
+ ln -s liblua5.3.so "$pkgdir/usr/lib/liblua.so.$pkgver"
+ cd "$pkgdir/usr/share/man/man1"
+ mv lua.1 lua5.3.0
+ mv luac.1 luac5.3.0
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/lua5.3/liblua.so.patch b/lua5.3/liblua.so.patch
new file mode 100644
index 0000000..7c02d02
--- /dev/null
+++ b/lua5.3/liblua.so.patch
@@ -0,0 +1,53 @@
+diff -ru lua-5.3.0-work1/Makefile lua-5.3.0-work1-patched/Makefile
+--- lua-5.3.0-work1/Makefile 2013-06-04 04:12:29.000000000 +0200
++++ lua-5.3.0-work1-patched/Makefile 2013-07-10 11:04:27.826555020 +0200
+@@ -10,7 +10,7 @@
+ # so take care if INSTALL_TOP is not an absolute path. See the local target.
+ # You may want to make INSTALL_LMOD and INSTALL_CMOD consistent with
+ # LUA_ROOT, LUA_LDIR, and LUA_CDIR in luaconf.h.
+-INSTALL_TOP= /usr/local
++INSTALL_TOP= /usr
+ INSTALL_BIN= $(INSTALL_TOP)/bin
+ INSTALL_INC= $(INSTALL_TOP)/include
+ INSTALL_LIB= $(INSTALL_TOP)/lib
+@@ -52,7 +52,7 @@
+ all: $(PLAT)
+
+ $(PLATS) clean:
+- cd src && $(MAKE) $@
++ cd src && $(MAKE) $@ V=$(V) R=$(R)
+
+ test: dummy
+ src/lua -v
+diff -ru lua-5.3.0-work1/src/Makefile lua-5.3.0-work1-patched/src/Makefile
+--- lua-5.3.0-work1/src/Makefile 2013-06-04 15:41:55.000000000 +0200
++++ lua-5.3.0-work1-patched/src/Makefile 2013-07-10 11:01:46.822761150 +0200
+@@ -29,6 +29,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+
+ LUA_A= liblua.a
++LUA_SO= liblua.so
+ CORE_O= lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+ lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+ ltm.o lundump.o lvm.o lzio.o
+@@ -43,7 +44,7 @@
+ LUAC_O= luac.o
+
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
+-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T) $(LUA_SO)
+ ALL_A= $(LUA_A)
+
+ # Targets start here.
+@@ -59,6 +60,11 @@
+ $(AR) $@ $(BASE_O)
+ $(RANLIB) $@
+
++$(LUA_SO): $(CORE_O) $(LIB_O)
++ $(CC) -shared -ldl -Wl,-soname,$(LUA_SO).$(V) -o $@.$(R) $? -lm $(MYLDFLAGS)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO).$(V)
++ ln -sf $(LUA_SO).$(R) $(LUA_SO)
++
+ $(LUA_T): $(LUA_O) $(LUA_A)
+ $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
+
diff --git a/lua5.3/lua.pc b/lua5.3/lua.pc
new file mode 100644
index 0000000..615fce2
--- /dev/null
+++ b/lua5.3/lua.pc
@@ -0,0 +1,20 @@
+V=%VER%
+R=%REL%
+
+prefix=/usr
+INSTALL_BIN=${prefix}/bin
+INSTALL_INC=${prefix}/include/5.3
+INSTALL_LIB=${prefix}/lib
+INSTALL_MAN=${prefix}/man/man1
+INSTALL_LMOD=${prefix}/share/lua/${V}
+INSTALL_CMOD=${prefix}/lib/lua/${V}
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include/5.3
+
+Name: Lua
+Description: An Extensible Extension Language
+Version: ${R}
+Requires:
+Libs: -L${libdir} -llua5.3 -lm
+Cflags: -I${includedir}