summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2013-07-06 14:54:30 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2013-07-06 14:54:30 +0200
commit62fa12b0fa8888701f61c34bae038c55f7a4a26c (patch)
tree891ae67da3fe8393a197b9f946b5cd066097c1d2
parent1a206b304968f4c5b2bd96ec5e67c2bf825515f1 (diff)
downloadarch-packages-62fa12b0fa8888701f61c34bae038c55f7a4a26c.tar.gz
add swig-git
-rw-r--r--Makefile6
-rw-r--r--swig-git/PKGBUILD53
2 files changed, 57 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index fc8cc2b..d9429da 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
# packages
SLNUNICODE = slnunicode-git
LUAMD5 = lua-md5-git
+SWIG = swig-git
# collections
-PKGS = $(SLNUNICODE) $(LUAMD5)
+PKGS = $(SLNUNICODE) $(LUAMD5) $(SWIG)
VERFY = $(PKGS:%=verify-%)
SOURCE = $(PKGS:%=source-%)
@@ -35,6 +36,7 @@ $(SOURCE):
# individual targets
slnunicode: $(SLNUNICODE)
luamd5: $(LUAMD5)
+swig: $(SWIG)
info:
@echo settings:
@@ -47,6 +49,6 @@ info:
@echo "all verify source"
@echo
@echo package targets:
- @echo "slnunicode" "luamd5"
+ @echo "slnunicode" "luamd5" "swig"
.PHONY: info all $(PKGS) clean $(VERFY) source $(SOURCE)
diff --git a/swig-git/PKGBUILD b/swig-git/PKGBUILD
new file mode 100644
index 0000000..961ef79
--- /dev/null
+++ b/swig-git/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Philipp Gesang <phg42.2a@gmail.com>
+#
+# header of the swig pkgbuild in extra:
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=swig-git
+pkgver=2.0.10
+pkgrel=1
+pkgdesc="Generate scripting interfaces to C/C++ code"
+arch=("i686" "x86_64")
+url="http://www.swig.org/"
+license=("custom")
+depends=("zlib" "pcre")
+makedepends=("git")
+conflicts=("swig")
+
+_gitroot="https://github.com/swig/swig"
+_gitname="swig"
+_gitbranch="master"
+
+source=("${_gitname}::git+https://github.com/swig/${_gitname}#branch=${_gitbranch}")
+sha1sums=("SKIP")
+
+build() {
+ cd "${srcdir}"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "${_gitname}" ]]; then
+ cd "${_gitname}" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "${_gitroot}" "${_gitname}"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "${srcdir}/${_gitname}-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-build"
+ make DESTDIR="${pkgdir}" install
+ #install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ #install -D -m644 LICENSE-UNIVERSITIES "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE-UNIVERSITIES
+}