summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2016-09-02 22:49:38 +0200
committerPhilipp Gesang <phg@phi-gamma.net>2016-09-02 22:49:38 +0200
commit02e0269831132642dab19142b61361d681903a6d (patch)
treeb9d077e40d89cc8bf60a2be6fd25220a4ed4f525
parentbd57a6c3e97637bef32ca827013f42941530ae20 (diff)
downloadarch-packages-02e0269831132642dab19142b61361d681903a6d.tar.gz
luatex-svn: include license files of subprojects
-rw-r--r--luatex-svn/PKGBUILD40
1 files changed, 38 insertions, 2 deletions
diff --git a/luatex-svn/PKGBUILD b/luatex-svn/PKGBUILD
index fe7382d..f0e88ec 100644
--- a/luatex-svn/PKGBUILD
+++ b/luatex-svn/PKGBUILD
@@ -8,7 +8,13 @@ pkgdesc="The LuaTeX engine, current SVN trunk, standalone binary"
pkgver=r6111
arch=(i686 x86_64)
url="http://www.luatex.org"
-license=('GPLv2')
+# Luatex, Poppler: GPL2
+# Fontforge: GPL (?)
+# Cairo, zziplib: LGPL
+# Luasocket, Luafilesystem, Luazip, Pixman: MIT
+# dotzlib: boost
+# libpng: libpng
+license=('GPL2' 'boost' 'MIT' 'libpng' 'LGPL2.1')
depends=()
makedepends=()
conflicts=()
@@ -55,6 +61,21 @@ check() {
[ -x "${bin}" ] || exit -1
}
+_install_legal ()
+{
+ # luatex includes numerous libraries, all linked in so we have to consider
+ # the individual licenses part of the package
+ local src="${1:-}"
+ local dst="${2:-}"
+ if [ -z "${src}" -o -z "${dst}" ]; then
+ msg "_install_legal(): junk “${src}” → “${dst}”; ignoring"
+ return
+ fi
+ local dstfull="${pkgdir}/usr/share/${pkgname}/legal/${dst}"
+ install -m644 "${src}" "${dstfull}"
+ gzip "${dstfull}" # empty repetitive jargon compresses very well
+}
+
package() {
local reporoot="${srcdir}/${_svnlocal}"
local bin="build/texk/web2c/luatex"
@@ -70,8 +91,23 @@ package() {
install -Dm644 build/doc/luatex.1.gz "${pkgdir}/usr/share/man/man1/"
msg "Package miscellaneous files"
install -dm755 "${pkgdir}/usr/share/${pkgname}/"
- install -Dm644 COPYING INSTALL README "${pkgdir}/usr/share/${pkgname}/"
install -Dm644 manual/luatex.pdf "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm644 INSTALL README "${pkgdir}/usr/share/${pkgname}/"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}/legal"
+ install -m644 COPYING "${pkgdir}/usr/share/${pkgname}/legal/COPYING.luatex"
+ local srclib=./source/libs
+ local luatexdir=./source/texk/web2c/luatexdir
+ _install_legal "${srclib}/pixman/pixman-src/COPYING" COPYING.pixman
+ _install_legal "${srclib}/cairo/cairo-src/COPYING" COPYING.cairo
+ _install_legal "${srclib}/libpng/libpng-src/contrib/gregbook/COPYING" COPYING.libpng
+ _install_legal "${srclib}/poppler/poppler-src/COPYING" COPYING.poppler
+ _install_legal "${srclib}/zziplib/zziplib-src/COPYING.LIB" COPYING.zziplib
+ _install_legal "${srclib}/zlib/zlib-src/contrib/dotzlib/LICENSE_1_0.txt" LICENSE.dotzlib
+ _install_legal "${srclib}/libpng/libpng-src/LICENSE" LICENSE.libpng
+ _install_legal "${luatexdir}/luafilesystem/doc/us/license.html" LICENSE.luafilesystem.html
+ _install_legal "${luatexdir}/luasocket/LICENSE" LICENSE.luasocket
+ _install_legal "${luatexdir}/luafontloader/fontforge/LICENSE" LICENSE.fontforge
+ _install_legal "${luatexdir}/luazip/doc/us/license.html" LICENSE.luazip.html
}
# vim:ft=sh:et:sw=2