summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2021-11-15 20:14:50 +0100
committerPhilipp Gesang <phg@phi-gamma.net>2021-11-15 20:14:17 +0100
commit3d5a3545f7d900177ecee5046d6660f878d96537 (patch)
tree02d2693e1c6d90771cd1f104f606772db5edd998 /Cargo.toml
parent10f04a80a878fd164ec01d4832f11c3cd63712eb (diff)
downloadvtcol-3d5a3545f7d900177ecee5046d6660f878d96537.tar.gz
decontaminate library from clap and anyhow deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 13 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 63c199b..d1483dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,17 +13,22 @@ readme = "README.rst"
license = "GPL-3.0"
edition = "2021"
+[dependencies]
+libc = "0.2"
+clap = { version = "2.33", optional = true }
+anyhow = { version = "1.0", optional = true }
+
+[features]
+vtcol-bin = [ "anyhow", "clap" ]
+
[[bin]]
-name = "vtcol"
-path = "src/vtcol.rs"
-test = false
-doc = false
+name = "vtcol"
+path = "src/vtcol.rs"
+test = false
+doc = false
+required-features = [ "vtcol-bin" ]
[lib]
# doctests suck
doctest = false
-[dependencies]
-clap = "2.33"
-libc = "0.2"
-anyhow = "1.0"