summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2021-11-15 20:43:27 +0100
committerPhilipp Gesang <phg@phi-gamma.net>2021-11-15 20:14:17 +0100
commit10f04a80a878fd164ec01d4832f11c3cd63712eb (patch)
tree79012206579cc059eec7a7f8eef989e453832602 /Cargo.toml
parentcc0eb0bce32255e95c1b86d9900209eee25a5951 (diff)
downloadvtcol-10f04a80a878fd164ec01d4832f11c3cd63712eb.tar.gz
lib: split out library
Not really a satisfactorily clean split as of yet but it’s a start. Error types have been changed from anyhow to io::Error in ``lib.rs`` so as to not force an error handling crate on downstream users.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 82eae4e..63c199b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,10 @@ path = "src/vtcol.rs"
test = false
doc = false
+[lib]
+# doctests suck
+doctest = false
+
[dependencies]
clap = "2.33"
libc = "0.2"